summaryrefslogtreecommitdiffstats
path: root/lib/libzfs/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2013-09-26 13:44:10 -0400
committerBrian Behlendorf <[email protected]>2013-10-10 16:56:51 -0700
commita6ce1eae54ca048ae7e7dfdcad05c5565a129226 (patch)
tree182cb119577a2c9c8db5d04d6daa54cdf05feeef /lib/libzfs/Makefile.am
parent31fc19399e597e3391f19f1392ab120f1de0d5f2 (diff)
Fix libzfs_core changes to follow GNU libtool guidelines
The GNU libtool documentation states to start with a version of 0:0:0, rather than 1:1:0. Illumos uses the name libzfs_core.so.1, so to be consistent, we should go with 1:0:0. http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info The GNU libtool documentation also provides guidence on how the version information should be incremented. Doing this does a SONAME bump of the libzfs and libzpool libraries. This is particularly important on Gentoo because a SONAME bump enables portage to retain the older libraries until any packages that link to them are rebuilt. The main example of this is GRUB2's grub2-mkconfig, which will break unless it is rebuilt against the new libraries. Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Issue #1751
Diffstat (limited to 'lib/libzfs/Makefile.am')
-rw-r--r--lib/libzfs/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libzfs/Makefile.am b/lib/libzfs/Makefile.am
index 75f1775a2..8b1f51782 100644
--- a/lib/libzfs/Makefile.am
+++ b/lib/libzfs/Makefile.am
@@ -28,4 +28,4 @@ libzfs_la_LIBADD = \
$(top_builddir)/lib/libzpool/libzpool.la
libzfs_la_LIBADD += -lm -ldl $(LIBBLKID)
-libzfs_la_LDFLAGS = -version-info 1:1:0
+libzfs_la_LDFLAGS = -version-info 2:0:0