aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libzfs/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-13 06:21:35 +0200
committerGitHub <[email protected]>2021-05-12 21:21:35 -0700
commit37086897b06a070d957226dbf860b4673906dc70 (patch)
treea430c4472b001d899eeee5bded50017d5d796300 /lib/libzfs/Makefile.am
parent7d07d1be39f4bc36930e304e36e95b712e379a5e (diff)
libzfs: add keylocation=https://, backed by fetch(3) or libcurl
Add support for http and https to the keylocation properly to allow encryption keys to be fetched from the specified URL. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Issue #9543 Closes #9947 Closes #11956
Diffstat (limited to 'lib/libzfs/Makefile.am')
-rw-r--r--lib/libzfs/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libzfs/Makefile.am b/lib/libzfs/Makefile.am
index 1a7698b47..31267fd9a 100644
--- a/lib/libzfs/Makefile.am
+++ b/lib/libzfs/Makefile.am
@@ -75,7 +75,7 @@ libzfs_la_LIBADD = \
$(abs_top_builddir)/lib/libnvpair/libnvpair.la \
$(abs_top_builddir)/lib/libuutil/libuutil.la
-libzfs_la_LIBADD += -lm $(LIBCRYPTO_LIBS) $(ZLIB_LIBS) $(LTLIBINTL)
+libzfs_la_LIBADD += -lm $(LIBCRYPTO_LIBS) $(ZLIB_LIBS) $(LIBFETCH_LIBS) $(LTLIBINTL)
libzfs_la_LDFLAGS = -pthread