summaryrefslogtreecommitdiffstats
path: root/lib/libuutil/Makefile.am
diff options
context:
space:
mode:
authorDarik Horn <[email protected]>2011-12-31 17:30:52 -0600
committerBrian Behlendorf <[email protected]>2012-01-17 15:19:50 -0800
commit750562833f5009e1602e3b7d8f10497ee683f611 (patch)
treeb06e59864c4f9a6466cc6e0de486572809888618 /lib/libuutil/Makefile.am
parent57a4eddc4d5e1e6c10d8d7dcf87a9fc27398adcd (diff)
Combine libraries: spl, avl, efi, share, unicode.
These libraries, which are an artifact of the ZoL development process, conflict with packages that are already in distribution: * libspl: SPL Programming Language * libavl: AVL for Linux * libefi: GRUB And these libraries are potential conflicts: * libshare: the Linux Mount Manager * libunicode: Perl and Python Recompose these five ZoL components into the four libraries that are conventionally provided by Solaris and FreeBSD systems: + libnvpair + libuutil + libzpool + libzfs This change resolves the name conflict, makes ZoL more compatible with existing software that uses autotools to detect ZFS, and allows pkg-zfs to better reflect the official Debian kFreeBSD packaging. Signed-off-by: Brian Behlendorf <[email protected]> Closes: #430
Diffstat (limited to 'lib/libuutil/Makefile.am')
-rw-r--r--lib/libuutil/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/lib/libuutil/Makefile.am b/lib/libuutil/Makefile.am
index f073cdbe4..2b2d5c1aa 100644
--- a/lib/libuutil/Makefile.am
+++ b/lib/libuutil/Makefile.am
@@ -8,8 +8,6 @@ DEFAULT_INCLUDES += \
lib_LTLIBRARIES = libuutil.la
-libuutil_la_LIBADD = $(top_builddir)/lib/libavl/libavl.la
-
libuutil_la_SOURCES = \
$(top_srcdir)/lib/libuutil/uu_alloc.c \
$(top_srcdir)/lib/libuutil/uu_avl.c \
@@ -22,4 +20,9 @@ libuutil_la_SOURCES = \
$(top_srcdir)/lib/libuutil/uu_string.c \
$(top_srcdir)/lib/libuutil/uu_strtoint.c
-libuutil_la_LDFLAGS = -version-info 1:0:0
+libuutil_la_LIBADD = \
+ $(top_builddir)/lib/libavl/libavl.la \
+ $(top_builddir)/lib/libspl/libspl.la \
+ $(top_builddir)/lib/libefi/libefi.la
+
+libuutil_la_LDFLAGS = -pthread -version-info 1:1:0