aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libunicode/Makefile.am
diff options
context:
space:
mode:
authorRich Ercolani <[email protected]>2022-03-31 13:09:18 -0400
committerTony Hutter <[email protected]>2022-09-21 16:12:14 -0700
commitebbbe01e31f6cdc79b32a8de2f50691972d184f7 (patch)
tree39c5430bac587a16db8996f792b5ac104346a894 /lib/libunicode/Makefile.am
parentd05f3039f7749508229e16b981723ec95c8764d1 (diff)
Ask libtool to stop hiding some errors
For #13083, curiously, it did not print the actual error, just that the compile failed with "Error 1". In theory, this flag should cause it to report errors twice sometimes. In practice, I'm pretty okay with reporting some twice if it avoids reporting some never. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Damian Szuberski <[email protected]> Signed-off-by: Rich Ercolani <[email protected]> Closes #13086
Diffstat (limited to 'lib/libunicode/Makefile.am')
-rw-r--r--lib/libunicode/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/libunicode/Makefile.am b/lib/libunicode/Makefile.am
index b82975f68..5b12b3e91 100644
--- a/lib/libunicode/Makefile.am
+++ b/lib/libunicode/Makefile.am
@@ -5,6 +5,9 @@ VPATH = $(top_srcdir)/module/unicode
# Includes kernel code, generate warnings for large stack frames
AM_CFLAGS += $(FRAME_LARGER_THAN)
+# See https://debbugs.gnu.org/cgi/bugreport.cgi?bug=54020
+AM_CFLAGS += -no-suppress
+
noinst_LTLIBRARIES = libunicode.la
KERNEL_C = \