summaryrefslogtreecommitdiffstats
path: root/lib/libspl/Makefile.am
diff options
context:
space:
mode:
authorDarik Horn <[email protected]>2011-12-31 17:30:52 -0600
committerBrian Behlendorf <[email protected]>2012-01-17 15:19:50 -0800
commit750562833f5009e1602e3b7d8f10497ee683f611 (patch)
treeb06e59864c4f9a6466cc6e0de486572809888618 /lib/libspl/Makefile.am
parent57a4eddc4d5e1e6c10d8d7dcf87a9fc27398adcd (diff)
Combine libraries: spl, avl, efi, share, unicode.
These libraries, which are an artifact of the ZoL development process, conflict with packages that are already in distribution: * libspl: SPL Programming Language * libavl: AVL for Linux * libefi: GRUB And these libraries are potential conflicts: * libshare: the Linux Mount Manager * libunicode: Perl and Python Recompose these five ZoL components into the four libraries that are conventionally provided by Solaris and FreeBSD systems: + libnvpair + libuutil + libzpool + libzfs This change resolves the name conflict, makes ZoL more compatible with existing software that uses autotools to detect ZFS, and allows pkg-zfs to better reflect the official Debian kFreeBSD packaging. Signed-off-by: Brian Behlendorf <[email protected]> Closes: #430
Diffstat (limited to 'lib/libspl/Makefile.am')
-rw-r--r--lib/libspl/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/libspl/Makefile.am b/lib/libspl/Makefile.am
index 586e6c0da..089056c56 100644
--- a/lib/libspl/Makefile.am
+++ b/lib/libspl/Makefile.am
@@ -11,7 +11,7 @@ DEFAULT_INCLUDES += \
AM_CCASFLAGS = \
-I$(top_srcdir)/lib/libspl/include
-lib_LTLIBRARIES = libspl.la
+noinst_LTLIBRARIES = libspl.la
libspl_la_SOURCES = \
$(top_srcdir)/lib/libspl/getexecname.c \
@@ -30,4 +30,4 @@ libspl_la_SOURCES = \
$(top_srcdir)/lib/libspl/include/sys/list.h \
$(top_srcdir)/lib/libspl/include/sys/list_impl.h
-libspl_la_LDFLAGS = -lrt -version-info 1:0:0
+libspl_la_LDFLAGS = -lrt