summaryrefslogtreecommitdiffstats
path: root/lib/libspl/Makefile.am
diff options
context:
space:
mode:
authorChunwei Chen <[email protected]>2016-10-26 00:32:23 -0400
committerBrian Behlendorf <[email protected]>2016-11-29 14:34:33 -0800
commit982957483450d53683681f456d1c84cfeb56afad (patch)
tree6efbe72e9a2b57474e855dae9d74377443bc9f27 /lib/libspl/Makefile.am
parent4f60152910c6bbc1c7975409f852af7ef11c7007 (diff)
ABD optimized page allocation code
* Convert ABD to use the Linux Kernel scatterlist implementation instead of the hand rolled one from illumos. * Scatter ABDs are preferentially populated with higher order compound pages from a single zone. Allocation size is progressively decreased until it can be satisfied without performing reclaim or compaction. * An alternate page allocator is provided for kernels older than 3.6 and for CONFIG_HIGHMEM systems. This allocator is designed as a fallback for maximum compatibility. * Extended abdstats to provide visibility in the the allocator. * Add cached value for PAGESIZE in userspace. Contributions-by: Chunwei Chen <[email protected]> Gvozden Neskovic <[email protected]> Jinshan Xiong <[email protected]> Isaac Huang <[email protected]> David Quigley <[email protected]> Brian Behlendorf <[email protected]>
Diffstat (limited to 'lib/libspl/Makefile.am')
-rw-r--r--lib/libspl/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/libspl/Makefile.am b/lib/libspl/Makefile.am
index afd64fcca..3c99529f1 100644
--- a/lib/libspl/Makefile.am
+++ b/lib/libspl/Makefile.am
@@ -24,6 +24,7 @@ USER_C = \
getmntany.c \
list.c \
mkdirp.c \
+ page.c \
strlcat.c \
strlcpy.c \
strnlen.c \