aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libnvpair/Makefile.am
diff options
context:
space:
mode:
authorTurbo Fredriksson <[email protected]>2014-06-09 23:55:31 +0200
committerBrian Behlendorf <[email protected]>2015-07-17 13:42:51 -0700
commit47a4a6fd5fa1f1f60bcf6af19e453ecf0292f7d1 (patch)
tree00c149a4fc58c4a0467c3ef68fbc29628966aa2b /lib/libnvpair/Makefile.am
parent2a53e2dacc7a7c0a8c63ff2eef3aff95f6ac80b1 (diff)
Support parallel build trees (VPATH builds)
Build products from an out of tree build should be written relative to the build directory. Sources should be referred to by their locations in the source directory. This is accomplished by adding the 'src' and 'obj' variables for the module Makefile.am, using relative paths to reference source files, and by setting VPATH when source files are not co-located with the Makefile. This enables the following: $ mkdir build $ cd build $ ../configure \ --with-spl=$HOME/src/git/spl/ \ --with-spl-obj=$HOME/src/git/spl/build $ make -s This change also has the advantage of resolving the following warning which is generated by modern versions of automake. Makefile.am:00: warning: source file 'xxx' is in a subdirectory, Makefile.am:00: but option 'subdir-objects' is disabled Signed-off-by: Turbo Fredriksson <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #1082
Diffstat (limited to 'lib/libnvpair/Makefile.am')
-rw-r--r--lib/libnvpair/Makefile.am25
1 files changed, 17 insertions, 8 deletions
diff --git a/lib/libnvpair/Makefile.am b/lib/libnvpair/Makefile.am
index 7a8f96a05..c9ac1f1fb 100644
--- a/lib/libnvpair/Makefile.am
+++ b/lib/libnvpair/Makefile.am
@@ -1,5 +1,9 @@
include $(top_srcdir)/config/Rules.am
+VPATH = \
+ $(top_srcdir)/module/nvpair \
+ $(top_srcdir)/lib/libnvpair
+
AM_CFLAGS += $(DEBUG_STACKFLAGS) $(FRAME_LARGER_THAN)
DEFAULT_INCLUDES += \
@@ -8,17 +12,22 @@ DEFAULT_INCLUDES += \
lib_LTLIBRARIES = libnvpair.la
-libnvpair_la_SOURCES = \
- $(top_srcdir)/lib/libnvpair/libnvpair.c \
- $(top_srcdir)/lib/libnvpair/nvpair_alloc_system.c \
- $(top_srcdir)/module/nvpair/nvpair_alloc_fixed.c \
- $(top_srcdir)/module/nvpair/nvpair.c \
- $(top_srcdir)/module/nvpair/fnvpair.c
+USER_C = \
+ libnvpair.c \
+ nvpair_alloc_system.c
+
+KERNEL_C = \
+ nvpair_alloc_fixed.c \
+ nvpair.c \
+ fnvpair.c
+
+nodist_libnvpair_la_SOURCES = \
+ $(USER_C) \
+ $(KERNEL_C)
libnvpair_la_LIBADD = \
$(top_builddir)/lib/libuutil/libuutil.la
libnvpair_la_LDFLAGS = -version-info 1:1:0
-EXTRA_DIST = \
- $(top_srcdir)/module/nvpair/nvpair_alloc_spl.c
+EXTRA_DIST = $(USER_C)