aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libnvpair/Makefile.am
diff options
context:
space:
mode:
authorAlek P <[email protected]>2018-03-19 15:40:58 -0400
committerBrian Behlendorf <[email protected]>2018-03-19 12:40:58 -0700
commit272b5d730f9ddd1db7cd7511da7bba75d6bd2450 (patch)
tree9c7d8a1e05571bc8b157427815e05fd65f1dfe91 /lib/libnvpair/Makefile.am
parenta76f3d0437e5e974f0f748f8735af3539443b388 (diff)
Add JSON output support to channel programs
The changes piggyback JSON output support on top of channel programs (#6558). This way the JSON output support is targeted to scripting use cases and is easily maintainable since it really only touches one function (zfs_do_channel_program()). This patch ports Joyent's JSON nvlist library from illumos to enable easy JSON printing of channel program output nvlist. To keep the delta small I also took advantage of the fact that printing in zfs_do_channel_program() was almost always done before exiting the program. Reviewed by: Matt Ahrens <[email protected]> Reviewed-by: Tony Hutter <[email protected]> Reviewed-by: Richard Elling <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Alek Pinchuk <[email protected]> Closes #7281
Diffstat (limited to 'lib/libnvpair/Makefile.am')
-rw-r--r--lib/libnvpair/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/libnvpair/Makefile.am b/lib/libnvpair/Makefile.am
index d6ba6f89a..8d6519f30 100644
--- a/lib/libnvpair/Makefile.am
+++ b/lib/libnvpair/Makefile.am
@@ -18,6 +18,7 @@ lib_LTLIBRARIES = libnvpair.la
USER_C = \
libnvpair.c \
+ libnvpair_json.c \
nvpair_alloc_system.c
KERNEL_C = \