aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-06-30 13:10:41 -0400
committerBrian Behlendorf <[email protected]>2020-07-10 14:26:00 -0700
commit4d61ade1a317606dc899e38b516410a0c2fdae0e (patch)
treed6c2003638fe28b2fe341515aaded236d6c1320f /lib/Makefile.am
parentb6437ea41c7611481925d72d294677434639b847 (diff)
Clean up lib dependencies
libzutil is currently statically linked into libzfs, libzfs_core and libzpool. Avoid the unnecessary duplication by removing it from libzfs and libzpool, and adding libzfs_core to libzpool. Remove a few unnecessary dependencies: - libuutil from libzfs_core - libtirpc from libspl - keep only libcrypto in libzfs, as we don't use any functions from libssl - librt is only used for clock_gettime, however on modern systems that's in libc rather than librt. Add a configure check to see if we actually need librt - libdl from raidz_test Add a few missing dependencies: - zlib to libefi and libzfs - libuuid to zpool, and libuuid and libudev to zed - libnvpair uses assertions, so add assert.c to provide aok and libspl_assertf Sort the LDADD for programs so that libraries that satisfy dependencies come at the end rather than the beginning of the linker command line. Revamp the configure tests for libaries to use FIND_SYSTEM_LIBRARY instead. This can take advantage of pkg-config, and it also avoids polluting LIBS. List all the required dependencies in the pkgconfig files, and move the one for libzfs_core into the latter's directory. Install pkgconfig files in $(libdir)/pkgconfig on linux and $(prefix)/libdata/pkgconfig on FreeBSD, instead of /usr/share/pkgconfig, as the more correct location for library .pc files. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10538
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4f59aa359..02e7f7b5f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
# NB: GNU Automake Manual, Chapter 8.3.5: Libtool Convenience Libraries
-# These six libraries are intermediary build components.
+# These eight libraries are intermediary build components.
SUBDIRS = libavl libicp libshare libspl libtpool
if BUILD_LINUX
@@ -9,6 +9,6 @@ endif
# libzutil depends on libefi if present
SUBDIRS += libzutil libunicode
-# These four libraries, which are installed as the final build product,
-# incorporate the six convenience libraries given above.
-SUBDIRS += libuutil libnvpair libzpool libzfs_core libzfs
+# These five libraries, which are installed as the final build product,
+# incorporate the eight convenience libraries given above.
+SUBDIRS += libuutil libnvpair libzfs_core libzfs libzpool