summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDarik Horn <[email protected]>2012-02-04 20:54:43 -0600
committerBrian Behlendorf <[email protected]>2012-02-07 11:37:15 -0800
commite67329d8e0befe79016bd3e4d52435552c554a52 (patch)
tree61f33256f36288b75c4535630603296a7a3be38b /lib/Makefile.am
parent47621f3d76abf63e178b95a446134565cc553b1a (diff)
Let libnvpair be linked independently of libzfs.
Autoconf will fail to detect the ZoL libnvpair on systems that do not implicitly link library runtime dependencies, which is anything that has the GCC 4.5 DCO update. Build libuutil before libnvpair, and put it on the the LDADD line of the libnvpair automake template. Signed-off-by: Brian Behlendorf <[email protected]> Closes: #560
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 51a8abd0c..09139d58c 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -4,4 +4,4 @@ SUBDIRS = libspl libavl libefi libshare libunicode
# These four libraries, which are installed as the final build product,
# incorporate the five convenience libraries given above.
-SUBDIRS += libnvpair libuutil libzpool libzfs
+SUBDIRS += libuutil libnvpair libzpool libzfs