summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDarik Horn <[email protected]>2011-12-31 17:30:52 -0600
committerBrian Behlendorf <[email protected]>2012-01-17 15:19:50 -0800
commit750562833f5009e1602e3b7d8f10497ee683f611 (patch)
treeb06e59864c4f9a6466cc6e0de486572809888618 /lib/Makefile.am
parent57a4eddc4d5e1e6c10d8d7dcf87a9fc27398adcd (diff)
Combine libraries: spl, avl, efi, share, unicode.
These libraries, which are an artifact of the ZoL development process, conflict with packages that are already in distribution: * libspl: SPL Programming Language * libavl: AVL for Linux * libefi: GRUB And these libraries are potential conflicts: * libshare: the Linux Mount Manager * libunicode: Perl and Python Recompose these five ZoL components into the four libraries that are conventionally provided by Solaris and FreeBSD systems: + libnvpair + libuutil + libzpool + libzfs This change resolves the name conflict, makes ZoL more compatible with existing software that uses autotools to detect ZFS, and allows pkg-zfs to better reflect the official Debian kFreeBSD packaging. Signed-off-by: Brian Behlendorf <[email protected]> Closes: #430
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0d518d220..51a8abd0c 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,2 +1,7 @@
-SUBDIRS = libspl libavl libefi libnvpair libshare
-SUBDIRS += libunicode libuutil libzpool libzfs
+# NB: GNU Automake Manual, Chapter 8.3.5: Libtool Convenience Libraries
+# These five libraries are intermediary build components.
+SUBDIRS = libspl libavl libefi libshare libunicode
+
+# These four libraries, which are installed as the final build product,
+# incorporate the five convenience libraries given above.
+SUBDIRS += libnvpair libuutil libzpool libzfs