aboutsummaryrefslogtreecommitdiffstats
path: root/include/vm/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2014-08-29 11:12:47 -0400
committerBrian Behlendorf <[email protected]>2014-10-28 09:31:48 -0700
commitfd05dde75d1abbb3dd906f9efa298b12ffc9d7d7 (patch)
tree5b9d06f79bfe9bb82c9e01203d6377ce163a5411 /include/vm/Makefile.am
parentad9863e80be35825229d0638c5e69c0ea30f82de (diff)
Kernel header installation should respect --prefix
This is the upstream component of work that enables preliminary support for building Gentoo's ZFS packaging on other Linux systems via Gentoo Prefix. Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #384
Diffstat (limited to 'include/vm/Makefile.am')
-rw-r--r--include/vm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/vm/Makefile.am b/include/vm/Makefile.am
index 413a6e325..7faab0aab 100644
--- a/include/vm/Makefile.am
+++ b/include/vm/Makefile.am
@@ -10,6 +10,6 @@ USER_H =
EXTRA_DIST = $(COMMON_H) $(KERNEL_H) $(USER_H)
if CONFIG_KERNEL
-kerneldir = /usr/src/spl-$(VERSION)/include/vm
+kerneldir = @prefix@/src/spl-$(VERSION)/include/vm
kernel_HEADERS = $(KERNEL_H)
endif