aboutsummaryrefslogtreecommitdiffstats
path: root/include/sys/lua/Makefile.am
diff options
context:
space:
mode:
authorChris Williamson <[email protected]>2018-02-08 09:16:23 -0700
committerBrian Behlendorf <[email protected]>2018-02-08 15:28:18 -0800
commitd99a015343425a1c856c900aa8223016400ac2dc (patch)
treef6ab517b27b650c32127953b74567baa99951d08 /include/sys/lua/Makefile.am
parent8824a7f133e4402f7176115cf8efd535c8cbdab2 (diff)
OpenZFS 7431 - ZFS Channel Programs
Authored by: Chris Williamson <[email protected]> Reviewed by: Matthew Ahrens <[email protected]> Reviewed by: George Wilson <[email protected]> Reviewed by: John Kennedy <[email protected]> Reviewed by: Dan Kimmel <[email protected]> Approved by: Garrett D'Amore <[email protected]> Ported-by: Don Brady <[email protected]> Ported-by: John Kennedy <[email protected]> OpenZFS-issue: https://www.illumos.org/issues/7431 OpenZFS-commit: https://github.com/openzfs/openzfs/commit/dfc11533 Porting Notes: * The CLI long option arguments for '-t' and '-m' don't parse on linux * Switched from kmem_alloc to vmem_alloc in zcp_lua_alloc * Lua implementation is built as its own module (zlua.ko) * Lua headers consumed directly by zfs code moved to 'include/sys/lua/' * There is no native setjmp/longjump available in stock Linux kernel. Brought over implementations from illumos and FreeBSD * The get_temporary_prop() was adapted due to VFS platform differences * Use of inline functions in lua parser to reduce stack usage per C call * Skip some ZFS Test Suite ZCP tests on sparc64 to avoid stack overflow
Diffstat (limited to 'include/sys/lua/Makefile.am')
-rw-r--r--include/sys/lua/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/include/sys/lua/Makefile.am b/include/sys/lua/Makefile.am
new file mode 100644
index 000000000..5f224dcb1
--- /dev/null
+++ b/include/sys/lua/Makefile.am
@@ -0,0 +1,21 @@
+COMMON_H = \
+ $(top_srcdir)/include/sys/lua/lua.h \
+ $(top_srcdir)/include/sys/lua/luaconf.h \
+ $(top_srcdir)/include/sys/lua/lualib.h \
+ $(top_srcdir)/include/sys/lua/lauxlib.h
+
+KERNEL_H =
+
+USER_H =
+
+EXTRA_DIST = $(COMMON_H) $(KERNEL_H) $(USER_H)
+
+if CONFIG_USER
+libzfsdir = $(includedir)/libzfs/sys/lua
+libzfs_HEADERS = $(COMMON_H) $(USER_H)
+endif
+
+if CONFIG_KERNEL
+kerneldir = @prefix@/src/zfs-$(VERSION)/include/sys/lua
+kernel_HEADERS = $(COMMON_H) $(KERNEL_H)
+endif