aboutsummaryrefslogtreecommitdiffstats
path: root/include/sys/lua/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-06-26 17:20:30 -0400
committerBrian Behlendorf <[email protected]>2020-06-27 17:40:14 -0700
commit4d8e68c42fb0bd5518f61670720af690fca302e0 (patch)
tree2398eee35e741d5ef16eb2a59579af7c17259600 /include/sys/lua/Makefile.am
parent67b1362f0492dc398b842d17d8aab59aa2272802 (diff)
Avoid installing kernel headers on FreeBSD
The kernel headers are installed for DKMS on linux, so don't install them unless we're building on linux. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10506
Diffstat (limited to 'include/sys/lua/Makefile.am')
-rw-r--r--include/sys/lua/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/sys/lua/Makefile.am b/include/sys/lua/Makefile.am
index e9d1185a4..8b4dafaa8 100644
--- a/include/sys/lua/Makefile.am
+++ b/include/sys/lua/Makefile.am
@@ -10,6 +10,8 @@ libzfs_HEADERS = $(COMMON_H)
endif
if CONFIG_KERNEL
+if BUILD_LINUX
kerneldir = @prefix@/src/zfs-$(VERSION)/include/sys/lua
kernel_HEADERS = $(COMMON_H)
endif
+endif