aboutsummaryrefslogtreecommitdiffstats
path: root/include/sys/fm/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-03-06 15:49:57 -0800
committerBrian Behlendorf <[email protected]>2013-03-06 15:49:57 -0800
commitea5c4389fb7183f036b38e5ba171ac5a05798c4d (patch)
tree6f9d829b6e5e86b2d81bda59d50db79e2660f2bd /include/sys/fm/Makefile.am
parent4bf3909e5186a978ea9bf5fb1409aa9777d40a35 (diff)
parent3d6af2dd6d598bebf6ab04d0e2b6f6ba6e5d0f00 (diff)
Merge branch 'build-system'
Diffstat (limited to 'include/sys/fm/Makefile.am')
-rw-r--r--include/sys/fm/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/include/sys/fm/Makefile.am b/include/sys/fm/Makefile.am
new file mode 100644
index 000000000..a073d2a3b
--- /dev/null
+++ b/include/sys/fm/Makefile.am
@@ -0,0 +1,14 @@
+COMMON_H =
+
+KERNEL_H = \
+ $(top_srcdir)/include/sys/fm/protocol.h \
+ $(top_srcdir)/include/sys/fm/util.h
+
+USER_H =
+
+EXTRA_DIST = $(COMMON_H) $(KERNEL_H) $(USER_H)
+
+if CONFIG_KERNEL
+kerneldir = /usr/src/spl-$(SPL_META_VERSION)-$(SPL_META_RELEASE)/$(LINUX_VERSION)/sys/fm
+kernel_HEADERS = $(KERNEL_H)
+endif