summaryrefslogtreecommitdiffstats
path: root/include/sys/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2016-04-13 08:55:35 -0700
committerBrian Behlendorf <[email protected]>2016-04-21 09:49:25 -0700
commitda5e151f207ff1bc4972ce74a3a85e442ffd5a03 (patch)
tree59fcc326b6ad69b36bc9f06bf1dd25a23afee34c /include/sys/Makefile.am
parent8fc5674c522e22f0b97e4714bf5410e24d481afa (diff)
Add pn_alloc()/pn_free() functions
In order to remove the HAVE_PN_UTILS wrappers the pn_alloc() and pn_free() functions must be implemented. The existing illumos implementation were used for this purpose. The `flags` argument which was used in places wrapped by the HAVE_PN_UTILS condition has beed added back to zfs_remove() and zfs_link() functions. This removes a small point of divergence between the ZoL code and upstream. Signed-off-by: Brian Behlendorf <[email protected]> Closes #4522
Diffstat (limited to 'include/sys/Makefile.am')
-rw-r--r--include/sys/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/sys/Makefile.am b/include/sys/Makefile.am
index 73e86d03b..98d7ad6fb 100644
--- a/include/sys/Makefile.am
+++ b/include/sys/Makefile.am
@@ -38,6 +38,7 @@ COMMON_H = \
$(top_srcdir)/include/sys/multilist.h \
$(top_srcdir)/include/sys/nvpair.h \
$(top_srcdir)/include/sys/nvpair_impl.h \
+ $(top_srcdir)/include/sys/pathname.h \
$(top_srcdir)/include/sys/range_tree.h \
$(top_srcdir)/include/sys/refcount.h \
$(top_srcdir)/include/sys/rrwlock.h \