summaryrefslogtreecommitdiffstats
path: root/include/sys/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-01-26 12:03:58 -0800
committerBrian Behlendorf <[email protected]>2011-02-10 09:27:21 -0800
commit1efb473f8919c5f195e127136b79c6d3b1eb1c81 (patch)
tree69937c80a49233c6ef948d3abf5bc19f52beeaee /include/sys/Makefile.am
parent633e8030b3582f3579a457a803c1382fc81f56e5 (diff)
Add Hooks for Linux File Operations
The Linux specific file operations have all been located in the file zpl_file.c. These functions primarily rely on the reworked zfs_* functions to do their job. They are also responsible for converting the possible Solaris style error codes to negative Linux errors. This first zpl_* commit also includes a common zpl.h header with minimal entries to register the Linux specific hooks. In also adds all the new zpl_* file to the Makefile.in. This is not a standalone commit, you required the following zpl_* commits.
Diffstat (limited to 'include/sys/Makefile.am')
-rw-r--r--include/sys/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/sys/Makefile.am b/include/sys/Makefile.am
index 63dc24e5b..bde71b75e 100644
--- a/include/sys/Makefile.am
+++ b/include/sys/Makefile.am
@@ -75,6 +75,7 @@ KERNEL_H = \
$(top_srcdir)/include/sys/blkdev.h \
$(top_srcdir)/include/sys/zfs_ioctl.h \
$(top_srcdir)/include/sys/zfs_onexit.h \
+ ${top_srcdir}/include/sys/zpl.h \
$(top_srcdir)/include/sys/zvol.h
USER_H =