aboutsummaryrefslogtreecommitdiffstats
path: root/include/sys/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-02-12 14:45:22 -0800
committerBrian Behlendorf <[email protected]>2009-02-12 14:45:22 -0800
commitf6c5d4ff88937fd69c938e0bc6ea11ad541e0a48 (patch)
treef24c06457dc2508e4f59f417f69c0b9ec9cce33b /include/sys/Makefile.am
parent37db7d8cf9936e6d2851a4329c11efcd9f61305c (diff)
Build system update
- Added default build flags: -Wall -Wstrict-prototypes -Werror -Wshadow - Added missing Makefile's for include/ subdirectories.
Diffstat (limited to 'include/sys/Makefile.am')
-rw-r--r--include/sys/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/include/sys/Makefile.am b/include/sys/Makefile.am
index 2eda85688..8fdb5afef 100644
--- a/include/sys/Makefile.am
+++ b/include/sys/Makefile.am
@@ -1,5 +1,3 @@
-EXTRA_DIST = callb.h cmn_err.h condvar.h cred.h
-EXTRA_DIST += debug.h kmem.h kstat.h
-EXTRA_DIST += mutex.h param.h random.h rwlock.h
-EXTRA_DIST += taskq.h thread.h time.h
-EXTRA_DIST += timer.h types.h
+SUBDIRS = fm fs sysevent
+
+EXTRA_DIST = *.h