aboutsummaryrefslogtreecommitdiffstats
path: root/include/sys/Makefile.am
diff options
context:
space:
mode:
authorPaul Dagnelie <[email protected]>2017-05-25 11:32:40 -0700
committerBrian Behlendorf <[email protected]>2018-06-06 09:35:59 -0700
commit37fb3e431845b934df9771d7bcca5fbef79f4c1e (patch)
tree352e34819910486a9a5ff9cb8870f4256c90afff /include/sys/Makefile.am
parentf0ed6c744872ec6dc4838947ffc597f4d141864a (diff)
OpenZFS 8484 - Implement aggregate sum and use for arc counters
In pursuit of improving performance on multi-core systems, we should implements fanned out counters and use them to improve the performance of some of the arc statistics. These stats are updated extremely frequently, and can consume a significant amount of CPU time. Authored by: Paul Dagnelie <[email protected]> Reviewed by: Pavel Zakharov <[email protected]> Reviewed by: Matthew Ahrens <[email protected]> Approved by: Dan McDonald <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Ported-by: Paul Dagnelie <[email protected]> OpenZFS-issue: https://www.illumos.org/issues/8484 OpenZFS-commit: https://github.com/openzfs/openzfs/commit/7028a8b92b7 Issue #3752 Closes #7462
Diffstat (limited to 'include/sys/Makefile.am')
-rw-r--r--include/sys/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/sys/Makefile.am b/include/sys/Makefile.am
index 06306b876..50c21831d 100644
--- a/include/sys/Makefile.am
+++ b/include/sys/Makefile.am
@@ -2,6 +2,7 @@ SUBDIRS = fm fs crypto lua sysevent
COMMON_H = \
$(top_srcdir)/include/sys/abd.h \
+ $(top_srcdir)/include/sys/aggsum.h \
$(top_srcdir)/include/sys/arc.h \
$(top_srcdir)/include/sys/arc_impl.h \
$(top_srcdir)/include/sys/avl.h \
@@ -11,6 +12,7 @@ COMMON_H = \
$(top_srcdir)/include/sys/bpobj.h \
$(top_srcdir)/include/sys/bptree.h \
$(top_srcdir)/include/sys/bqueue.h \
+ $(top_srcdir)/include/sys/cityhash.h \
$(top_srcdir)/include/sys/dbuf.h \
$(top_srcdir)/include/sys/ddt.h \
$(top_srcdir)/include/sys/dmu.h \