aboutsummaryrefslogtreecommitdiffstats
path: root/include/os/freebsd/linux/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-06-25 14:14:54 -0400
committerBrian Behlendorf <[email protected]>2020-06-26 14:20:02 -0700
commit6b99fc0620f00fcfd201595b2bc6d279031dcb09 (patch)
treecc5149529e1148acaae62dc46b47b39c5090439e /include/os/freebsd/linux/Makefile.am
parent7c902a5178496f1321ecb9f33df743a77278089e (diff)
Fixes for make dist
Reduce the usage of EXTRA_DIST. If files are conditionally included in _SOURCES, _HEADERS etc, automake is smart enough to dist all files that could possibly be included, but this does not apply to EXTRA_DIST, resulting in make dist depending on the configuration. Add some files that were missing altogether in various Makefile's. The changes to disted files in this commit (excluding deleted files): +./cmd/zed/agents/README.md +./etc/init.d/README.md +./lib/libspl/os/freebsd/getexecname.c +./lib/libspl/os/freebsd/gethostid.c +./lib/libspl/os/freebsd/getmntany.c +./lib/libspl/os/freebsd/mnttab.c -./lib/libzfs/libzfs_core.pc -./lib/libzfs/libzfs.pc +./lib/libzfs/os/freebsd/libzfs_compat.c +./lib/libzfs/os/freebsd/libzfs_fsshare.c +./lib/libzfs/os/freebsd/libzfs_ioctl_compat.c +./lib/libzfs/os/freebsd/libzfs_zmount.c +./lib/libzutil/os/freebsd/zutil_compat.c +./lib/libzutil/os/freebsd/zutil_device_path_os.c +./lib/libzutil/os/freebsd/zutil_import_os.c +./module/lua/README.zfs +./module/os/linux/spl/README.md +./tests/README.md +./tests/zfs-tests/tests/functional/cli_root/zfs_clone/zfs_clone_rm_nested.ksh +./tests/zfs-tests/tests/functional/cli_root/zfs_send/zfs_send_encrypted_unloaded.ksh +./tests/zfs-tests/tests/functional/inheritance/README.config +./tests/zfs-tests/tests/functional/inheritance/README.state +./tests/zfs-tests/tests/functional/rsend/rsend_016_neg.ksh +./tests/zfs-tests/tests/perf/fio/sequential_readwrite.fio Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10501
Diffstat (limited to 'include/os/freebsd/linux/Makefile.am')
-rw-r--r--include/os/freebsd/linux/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/os/freebsd/linux/Makefile.am b/include/os/freebsd/linux/Makefile.am
index 7168fc7a1..df902b87a 100644
--- a/include/os/freebsd/linux/Makefile.am
+++ b/include/os/freebsd/linux/Makefile.am
@@ -2,4 +2,7 @@ KERNEL_H = \
compiler.h \
types.h
-EXTRA_DIST = $(KERNEL_H)
+if CONFIG_KERNEL
+kerneldir = @prefix@/src/zfs-$(VERSION)/include/linux
+kernel_HEADERS = $(KERNEL_H)
+endif