summaryrefslogtreecommitdiffstats
path: root/include/linux/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2014-10-01 15:02:12 -0400
committerBrian Behlendorf <[email protected]>2014-10-17 14:58:57 -0700
commitf0e324f25d5ada5da5f8930fc1789af6896c72b4 (patch)
tree33c81bcfd6c68a7844952f4ea356ed2bfe88d480 /include/linux/Makefile.am
parent050d22b06834876c3b0554647108f06a05b3ba96 (diff)
Update utsname support
Modify the code to use the utsname() kernel function rather than a global variable. This results is cleaner more portable code because utsname() is already provided by the kernel and can be easily emulated in user space via uname(2). This means that it will behave consistently in both contexts. This is also has the benefit that it allows the removal of a few _KERNEL pre-processor conditions. And it also is a pre-requisite for a proper FUSE port because we need to provide a valid utsname. Finally, it allows us to remove this functionality from the SPL and all the related compatibility code. Signed-off-by: Brian Behlendorf <[email protected]> Issue #2757
Diffstat (limited to 'include/linux/Makefile.am')
-rw-r--r--include/linux/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/linux/Makefile.am b/include/linux/Makefile.am
index c2a749121..fc2df090e 100644
--- a/include/linux/Makefile.am
+++ b/include/linux/Makefile.am
@@ -4,7 +4,8 @@ KERNEL_H = \
$(top_srcdir)/include/linux/dcache_compat.h \
$(top_srcdir)/include/linux/xattr_compat.h \
$(top_srcdir)/include/linux/vfs_compat.h \
- $(top_srcdir)/include/linux/blkdev_compat.h
+ $(top_srcdir)/include/linux/blkdev_compat.h \
+ $(top_srcdir)/include/linux/utsname_compat.h
USER_H =