summaryrefslogtreecommitdiffstats
path: root/include/linux/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-02-11 08:58:55 -0800
committerBrian Behlendorf <[email protected]>2011-02-11 09:05:51 -0800
commit7268e1bec8478639b7a1047e02ab931f30bc2f92 (patch)
treef3351407cbadd80f457d2d363541135865d82ebe /include/linux/Makefile.am
parent777d4af89137907adc91377327505f40c296035d (diff)
Linux 2.6.35 compat, fops->fsync()
The fsync() callback in the file_operations structure used to take 3 arguments. The callback now only takes 2 arguments because the dentry argument was determined to be unused by all consumers. To handle this a compatibility prototype was added to ensure the right prototype is used. Our implementation never used the dentry argument either so it's just a matter of using the right prototype.
Diffstat (limited to 'include/linux/Makefile.am')
-rw-r--r--include/linux/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/linux/Makefile.am b/include/linux/Makefile.am
index 67b56f83d..0ea6cfeda 100644
--- a/include/linux/Makefile.am
+++ b/include/linux/Makefile.am
@@ -1,8 +1,9 @@
COMMON_H =
KERNEL_H = \
- $(top_srcdir)/include/linux/dcache_compat.h
- $(top_srcdir)/include/linux/xattr_compat.h
+ $(top_srcdir)/include/linux/dcache_compat.h \
+ $(top_srcdir)/include/linux/xattr_compat.h \
+ $(top_srcdir)/include/linux/vfs_compat.h
USER_H =