summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-03-05 09:08:07 -0800
committerBrian Behlendorf <[email protected]>2009-03-09 15:56:55 -0700
commitc5f704607bbdc5e6a89b4ac088dff16a6c1eeb5e (patch)
tree182cb70d67bde33e9697623ca0b0533985407528 /include/Makefile.am
parent32f74c5280ca9a753991b97370e7c4c1a4e34ede (diff)
Build system and packaging (RPM support)
An update to the build system to properly support all commonly used Makefile targets these include: make all # Build everything make install # Install everything make clean # Clean up build products make distclean # Clean up everything make dist # Create package tarball make srpm # Create package source RPM make rpm # Create package binary RPMs make tags # Create ctags and etags for everything Extra care was taken to ensure that the source RPMs are fully rebuildable against Fedora/RHEL/Chaos kernels. To build binary RPMs from the source RPM for your system simply run: rpmbuild --rebuild spl-x.y.z-1.src.rpm This will produce two binary RPMs with correct 'requires' dependencies for your kernel. One will contain all spl modules and support utilities, the other is a devel package for compiling additional kernel modules which are dependant on the spl. spl-x.y.z-1_<kernel version>.x86_64.rpm spl-devel-x.y.2-1_<kernel version>.x86_64.rpm
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index de6312f1e..0b58dd9f8 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,3 +1,15 @@
-SUBDIRS = asm linux rpc sys util fs sharefs vm
-
-EXTRA_DIST = *.h
+# All headers are referenced by this top level Makefile.am and the
+# nobase_* rule is used to ensure all path information is preserved
+# when using the 'make install' target.
+nobase_include_HEADERS = *.h
+nobase_include_HEADERS += asm/*.h
+nobase_include_HEADERS += fs/*.h
+nobase_include_HEADERS += linux/*.h
+nobase_include_HEADERS += rpc/*.h
+nobase_include_HEADERS += sharefs/*.h
+nobase_include_HEADERS += sys/fm/*.h
+nobase_include_HEADERS += sys/fs/*.h
+nobase_include_HEADERS += sys/sysevent/*.h
+nobase_include_HEADERS += sys/*.h
+nobase_include_HEADERS += util/*.h
+nobase_include_HEADERS += vm/*.h