summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-01-18 11:42:25 -0800
committerBrian Behlendorf <[email protected]>2011-02-10 09:25:10 -0800
commit8299a1f41eb4761cd25ea821830295a6f32be581 (patch)
treeaf1b483413f6c689ec7f8d2b6fcd49012d3ab22c /include/Makefile.am
parentab892c5f0ad7c2ee291693cf61dfc9601a2472d0 (diff)
Add Linux Compat Infrastructure
Lay the initial ground work for a include/linux/ compatibility directory. This was less critical in the past because the bulk of the ZFS code consumes the Solaris API via the SPL. This API was stable and the bulk Linux API differences were handled in the SPL. However, with the addition of a full Posix layer written directly against the Linux APIs we are going to need more compatibility code. It makes sense that all this code should be cleanly located in one place. Subsequent patches should move the existing zvol and vdev_disk compatibility code in to this directory.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0926c6a69..1d7493bb5 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = sys
+SUBDIRS = linux sys
COMMON_H = \
$(top_srcdir)/include/zfs_comutil.h \