summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2012-01-17 16:14:35 -0800
committerBrian Behlendorf <[email protected]>2012-01-18 11:06:26 -0800
commita2eda2ff48e6c38788d48b121f36ff7d280d569b (patch)
treea2fa9575010e8a639c565079f203fc393b0a432c /include/Makefile.am
parentec2b41049f7f576aaa772b326d083e5971212d33 (diff)
Add the release component to headers
When the original build system code was added the release component was accidentally omited from the development header install path. This patch adds the missing path component so it's always clear exactly what release your compiling against. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index d1289f0a0..31acf7e99 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,14 +15,14 @@ noinst_HEADERS += $(top_srcdir)/include/util/*.h
noinst_HEADERS += $(top_srcdir)/include/vm/*.h
install-data-local:
- destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
- instdest=$(DESTDIR)/usr/src/$$destname; \
+ release=$(SPL_META_VERSION)-$(SPL_META_RELEASE); \
+ instdest=$(DESTDIR)/usr/src/spl-$$release/$(LINUX_VERSION); \
instfiles=`find . -name '*.h'`; \
for instfile in $$instfiles; do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \
done
uninstall-local:
- destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
- instdest=$(DESTDIR)/usr/src/$$destname; \
+ release=$(SPL_META_VERSION)-$(SPL_META_RELEASE); \
+ instdest=$(DESTDIR)/usr/src/spl-$$release/$(LINUX_VERSION); \
$(RM) -R $$instdest