summaryrefslogtreecommitdiffstats
path: root/etc/udev/rules.d/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-03-24 11:34:41 -0700
committerBrian Behlendorf <[email protected]>2011-03-25 10:05:09 -0700
commit1d82906dea5eb698a854d992e445e794fb5a0880 (patch)
tree99b4da105796b83317173749e85071f259e6da83 /etc/udev/rules.d/Makefile.am
parenta5729f7b22e14aed657bd716f3ee98b02f7e7c41 (diff)
Set cmd paths in udev rules using --prefix
The udev/rules.d scripts must use absolute paths to their support binaries. However, where those binaries get installed depends on what --prefix was set to when the package was configured. This change makes the udev/rules.d helpers to *.in files which are processed by configure. This allows them to be dynamically updated to include the specified --prefix. Additionally, this change updates 60-zvol.rules to handle both the 'add' and 'change' actions. This ensures that that all valid zvol devices are correctly linked.
Diffstat (limited to 'etc/udev/rules.d/Makefile.am')
-rw-r--r--etc/udev/rules.d/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/etc/udev/rules.d/Makefile.am b/etc/udev/rules.d/Makefile.am
index 04536007a..1a7a1e392 100644
--- a/etc/udev/rules.d/Makefile.am
+++ b/etc/udev/rules.d/Makefile.am
@@ -4,4 +4,7 @@ pkgsysconf_DATA = \
60-zpool.rules \
60-zvol.rules
-EXTRA_DIST = $(pkgsysconf_DATA)
+EXTRA_DIST = 60-zpool.rules.in 60-zvol.rules.in
+
+distclean-local::
+ -$(RM) $(pkgsysconf_DATA)