summaryrefslogtreecommitdiffstats
path: root/etc/init.d/Makefile.am
diff options
context:
space:
mode:
authorCarlo Landmeter <[email protected]>2016-03-01 16:36:28 +0100
committerBrian Behlendorf <[email protected]>2016-03-08 13:19:53 -0800
commitc53fb0113cc372ed8df3c08f59f83cb3ceee849b (patch)
tree4f349572cb1897fb139914c1e82a8905347da17f /etc/init.d/Makefile.am
parent513168abd267f84ebcb688b4e1d42a2abd4fedce (diff)
Add support for alpine linux
Both Alpine Linux and Gentoo use OpenRC so we share its logic Signed-off-by: Carlo Landmeter <[email protected]> Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #4386
Diffstat (limited to 'etc/init.d/Makefile.am')
-rw-r--r--etc/init.d/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/etc/init.d/Makefile.am b/etc/init.d/Makefile.am
index 5f70fc658..c6e29d1a5 100644
--- a/etc/init.d/Makefile.am
+++ b/etc/init.d/Makefile.am
@@ -21,7 +21,7 @@ $(init_SCRIPTS) $(initconf_SCRIPTS) $(initcommon_SCRIPTS): $(EXTRA_DIST)
else \
NFS_SRV=nfs; \
fi; \
- if [ -e /etc/gentoo-release ]; then \
+ if [ -e /sbin/openrc-run ]; then \
SHELL=/sbin/runscript; \
else \
SHELL=/bin/sh; \