aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/pyzfs/setup.py
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2019-01-06 10:41:16 -0800
committerBrian Behlendorf <[email protected]>2019-01-06 10:54:12 -0800
commitc87db591967507de027d6bb0c683ffd09dd70105 (patch)
treee308115e563c7011194dc55d4f3bd65c0ec664b1 /contrib/pyzfs/setup.py
parent0b8e4418b615eb6e46d409b3de61bfffe1000c68 (diff)
parentdffce3c282f74991e740c1e1887001fe059fe05a (diff)
Python 2 and 3 compatibility
With Python 2 (slowly) approaching EOL and its removal from distribitions already being planned (Fedora), the existing Python 2 code needs to be transitioned to Python 3. This patch stack updates the Python code to be compatible with Python 2.7, 3.4, 3.5, 3.6, and 3.7. Reviewed-by: John Ramsden <[email protected]> Reviewed-by: Neal Gompa <[email protected]> Reviewed-by: loli10K <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: John Wren Kennedy <[email protected]> Reviewed-by: Antonio Russo <[email protected]> Closes #8096
Diffstat (limited to 'contrib/pyzfs/setup.py')
-rw-r--r--contrib/pyzfs/setup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/contrib/pyzfs/setup.py b/contrib/pyzfs/setup.py
index 3baa25c1b..3ff6c04c6 100644
--- a/contrib/pyzfs/setup.py
+++ b/contrib/pyzfs/setup.py
@@ -13,6 +13,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
+from __future__ import absolute_import, division, print_function
from setuptools import setup, find_packages
@@ -28,8 +29,13 @@ setup(
"Development Status :: 4 - Beta",
"Intended Audience :: Developers",
"License :: OSI Approved :: Apache Software License",
- "Programming Language :: Python :: 2 :: Only",
+ "Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Topic :: System :: Filesystems",
"Topic :: Software Development :: Libraries",
],
@@ -47,7 +53,7 @@ setup(
setup_requires=[
"cffi",
],
- python_requires='>=2.7,<3',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,<4',
zip_safe=False,
test_suite="libzfs_core.test",
)