aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/initramfs/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-21 23:43:38 +0200
committerBrian Behlendorf <[email protected]>2021-06-09 13:05:34 -0700
commit132240507d0ab2999e764537b181e89ecc3c2b0e (patch)
tree3450e3a8132bbdc611944445146f259e541a0261 /contrib/initramfs/Makefile.am
parentd6f8f41c21b42a1b5a36850c0f7b18be9a05ecd9 (diff)
Turn shellcheck into a normal make target. Fix new files it caught
This checks every file it checked (and a few more), but explicitly instead of "if it works it works" best-effort (which wasn't that good anyway) Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #10512 Closes #12101
Diffstat (limited to 'contrib/initramfs/Makefile.am')
-rw-r--r--contrib/initramfs/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/initramfs/Makefile.am b/contrib/initramfs/Makefile.am
index 5eac6e215..931ceb131 100644
--- a/contrib/initramfs/Makefile.am
+++ b/contrib/initramfs/Makefile.am
@@ -1,9 +1,12 @@
+include $(top_srcdir)/config/Shellcheck.am
+
initrddir = /usr/share/initramfs-tools
dist_initrd_SCRIPTS = \
zfsunlock
SUBDIRS = conf.d conf-hooks.d hooks scripts
+SHELLCHECKDIRS = hooks scripts
EXTRA_DIST = \
README.initramfs.markdown