summaryrefslogtreecommitdiffstats
path: root/contrib/dracut/90zfs/Makefile.am
diff options
context:
space:
mode:
authorMatthew Thode <[email protected]>2016-03-30 18:59:15 -0500
committerBrian Behlendorf <[email protected]>2016-04-25 08:51:38 -0700
commita5a370227eb0a3daf8992a38920d54eb3b7b3c25 (patch)
treecc85181222f7cd64ff79c9eae7013588730977c2 /contrib/dracut/90zfs/Makefile.am
parent232604b58e8579501c5a260ad3a7b71a239dd546 (diff)
fix booting via dracut generated initramfs
Dracut and Systemd updated how they integrate with each other, because of this our current integrations stopped working (around the time 4.1.13 came out). This patch addresses that issue and gets us booting again. Thanks to @Rudd-O for doing the work to get dracut working again and letting me submit this on his behalf. Signed-off-by: Manuel Amador (Rudd-O) <[email protected]> Signed-off-by: Matthew Thode <[email protected]> Closes #3605 Closes #4478
Diffstat (limited to 'contrib/dracut/90zfs/Makefile.am')
-rw-r--r--contrib/dracut/90zfs/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/dracut/90zfs/Makefile.am b/contrib/dracut/90zfs/Makefile.am
index b778a2744..f81d6c357 100644
--- a/contrib/dracut/90zfs/Makefile.am
+++ b/contrib/dracut/90zfs/Makefile.am
@@ -4,6 +4,7 @@ pkgdracut_SCRIPTS = \
module-setup.sh \
mount-zfs.sh \
parse-zfs.sh \
+ zfs-generator.sh \
zfs-lib.sh
EXTRA_DIST = \
@@ -11,6 +12,7 @@ EXTRA_DIST = \
$(top_srcdir)/contrib/dracut/90zfs/module-setup.sh.in \
$(top_srcdir)/contrib/dracut/90zfs/mount-zfs.sh.in \
$(top_srcdir)/contrib/dracut/90zfs/parse-zfs.sh.in \
+ $(top_srcdir)/contrib/dracut/90zfs/zfs-generator.sh.in \
$(top_srcdir)/contrib/dracut/90zfs/zfs-lib.sh.in
$(pkgdracut_SCRIPTS):
@@ -19,6 +21,7 @@ $(pkgdracut_SCRIPTS):
-e 's,@udevdir\@,$(udevdir),g' \
-e 's,@udevruledir\@,$(udevruledir),g' \
-e 's,@sysconfdir\@,$(sysconfdir),g' \
+ -e 's,@systemdunitdir\@,$(systemdunitdir),g' \
"$(top_srcdir)/contrib/dracut/90zfs/[email protected]" >'$@'
distclean-local::