aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-10 00:16:59 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:19:44 -0700
commit50d2c9e4fd2a891cad9530da39b39a173307e1f7 (patch)
tree105fe338bda713bc53b134540da5435bca854de2 /contrib/Makefile.am
parent674a9f3727f6e54fb3a391d4d6257a96f3a81a6e (diff)
autoconf: use include directives instead of recursing down contrib
Also make the pyzfs build actually out-of-tree and quiet by default Reviewed-by: Brian Behlendorf <[email protected]> Co-authored-by: Rapptz <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 5ec13ece5..fa51bd941 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,12 +1,13 @@
-include $(top_srcdir)/config/Shellcheck.am
+include $(srcdir)/%D%/bash_completion.d/Makefile.am
+include $(srcdir)/%D%/pyzfs/Makefile.am
+include $(srcdir)/%D%/zcp/Makefile.am
-SUBDIRS = bash_completion.d pyzfs zcp
if BUILD_LINUX
-SUBDIRS += bpftrace dracut initramfs
+include $(srcdir)/%D%/bpftrace/Makefile.am
+include $(srcdir)/%D%/dracut/Makefile.am
+include $(srcdir)/%D%/initramfs/Makefile.am
endif
+
if PAM_ZFS_ENABLED
-SUBDIRS += pam_zfs_key
+include $(srcdir)/%D%/pam_zfs_key/Makefile.am
endif
-DIST_SUBDIRS = bash_completion.d bpftrace dracut initramfs pam_zfs_key pyzfs zcp
-
-SHELLCHECKDIRS = bash_completion.d bpftrace dracut initramfs