aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorDamian Szuberski <[email protected]>2021-11-30 19:23:10 +0100
committerGitHub <[email protected]>2021-11-30 10:23:10 -0800
commit34eef3e9a7a74d24a59d016051d547afc55dbaa0 (patch)
treec75ff6fda4ee9582ed2ebb5b1a71a529242c3d78 /contrib/Makefile.am
parent4325de09cd2993837bc32a83d61872b57e58298e (diff)
Pass `--enable=all` to shellcheck within contrib/
- Remove `SHELLCHECK_IGNORE` in favor of inline suppressions and more general `SHELLCHECK_OPTS`. - Exclude `SC2250` (turned on by `--enable=all`) globally - Pass `--enable=all` to shellcheck for scripts in contrib/: it's very important to catch errors early in areas that are not easily testable. Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: szubersk <[email protected]> Closes #12760
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 5ec13ece5..f13b5f9f6 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -10,3 +10,4 @@ endif
DIST_SUBDIRS = bash_completion.d bpftrace dracut initramfs pam_zfs_key pyzfs zcp
SHELLCHECKDIRS = bash_completion.d bpftrace dracut initramfs
+SHELLCHECK_OPTS = --enable=all