aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorbehlendo <behlendo@7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c>2008-02-27 00:59:48 +0000
committerbehlendo <behlendo@7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c>2008-02-27 00:59:48 +0000
commit3d4ea0ced6c2400d2b7d62d4f90b1a69d7e1a04e (patch)
tree20203a08fe43cd7855c7b23c9e1ce2f198681d14 /configure.ac
parent564f6d1509f71f14e0bd9631363995b7f193d758 (diff)
More build fixes, I have the kernel module almost building and its
feeling a lot more sane, cleaner, and linuxy. I may finish this tonight. git-svn-id: https://outreach.scidac.gov/svn/spl/trunk@4 7e1ea52c-4ff2-0310-8f11-9dd32ca42a1c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 833514dc1..215b5091c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,8 +9,6 @@ AC_PROG_CC
AC_PROG_LIBTOOL
ver=`uname -r`
-KERNELCFLAGS=
-
kernelsrc=
kernelbuild=
AC_ARG_WITH(kernel,
@@ -98,6 +96,10 @@ else
AC_MSG_RESULT([no])
fi
+# Add "V=1" to KERNELMAKE_PARAMS to enable verbose module build
+KERNELMAKE_PARAMS=
+KERNELCPPFLAGS="-I`/bin/pwd`/include"
+
if test "$kernelbuild" != "$kernelsrc"; then
KERNELMAKE_PARAMS="$KERNELMAKE_PARAMS O=$kernelbuild"
fi