summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-03-17 14:55:59 -0700
committerBrian Behlendorf <[email protected]>2009-03-17 14:55:59 -0700
commit0cbaeb117ae0e77d05c7709a4f5dbfad9daa799f (patch)
tree81a09cc96cc7ad76168081200834ac03614fae82 /configure.ac
parente11d6c5f50ff1cb9a75f5c6a6895846f73564422 (diff)
Allow spl_config.h to be included by dependant packages
We need dependent packages to be able to include spl_config.h so they can leverage the configure checks the SPL has done. This is important because several of the spl headers need the results of these checks to work properly. Unfortunately, the autoheader build product is always private to a particular build and defined certain common things. (PACKAGE, VERSION, etc). This prevents other packages which also use autoheader from being include because the definitions conflict. To avoid this problem the SPL build system leverage AH_BOTTOM to include a spl_unconfig.h at the botton of the autoheader build product. This custom include undefs all known shared symbols to prevent the confict. This does however mean that those definition are also not availble to the SPL package either. The SPL package therefore uses the equivilant SPL_META_* definitions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdec31c4b..b6abe7a8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,7 @@ AC_CONFIG_AUX_DIR([config])
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE([$SPL_META_NAME], [$SPL_META_VERSION])
AC_CONFIG_HEADERS([spl_config.h])
+AH_BOTTOM([#include <spl_unconfig.h>])
AM_MAINTAINER_MODE
AC_PROG_INSTALL