aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHajo Möller <[email protected]>2015-03-12 23:41:24 +0100
committerBrian Behlendorf <[email protected]>2015-03-25 11:16:08 -0700
commita4f54cf036d9a966ff87abe9a0063f2b457c2389 (patch)
treeb3efad96dc4ae20faa7c2f97e4c5d3d343edb40a /configure.ac
parentabb642b9a971e6c1a15816f9332da89eaebac9c1 (diff)
Fix warning about AM_INIT_AUTOMAKE arguments
As of automake 1.14.2, currently shipped with Ubuntu 14.04, automake warns about AM_INIT_AUTOMAKE having more than one argument: configure.ac:41: warning: AM_INIT_AUTOMAKE: two- and three-arguments forms are deprecated. For more info, see: configure.ac:41: http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation This commit fixes the warnings by following above link's advice, so AM_INIT gets called with the package's name and version. As both are defined in the META file we're parsing it with `grep`, `cut` and `tr`. NOTE: autoconf < 1.14 not supporting m4_esyscmd_s so m4_esyscmd was used and modified `tr` to truncate newlines, too. Signed-off-by: Hajo M<C3><B6>ller <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #438
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e81ddfbc8..9746659e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,8 @@
# with the SPL. If not, see <http://www.gnu.org/licenses/>.
###############################################################################
-AC_INIT
+AC_INIT(m4_esyscmd(grep Name META | cut -d ':' -f 2 | tr -d ' \n'),
+ m4_esyscmd(grep Version META | cut -d ':' -f 2 | tr -d ' \n'))
AC_LANG(C)
SPL_AC_META
AC_CONFIG_AUX_DIR([config])
@@ -32,7 +33,7 @@ AC_CONFIG_MACRO_DIR([config])
AC_CANONICAL_SYSTEM
AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-AM_INIT_AUTOMAKE([$SPL_META_NAME], [$SPL_META_VERSION])
+AM_INIT_AUTOMAKE
AC_CONFIG_HEADERS([spl_config.h], [
(mv spl_config.h spl_config.h.tmp &&
awk -f ${ac_srcdir}/config/config.awk spl_config.h.tmp >spl_config.h &&