summaryrefslogtreecommitdiffstats
path: root/cmd/zpool/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-06-05 13:52:15 -0400
committerBrian Behlendorf <[email protected]>2017-06-05 10:52:15 -0700
commit099700d9dff46309cdd16f4c4331daddb70d8570 (patch)
tree13383ee2af7cc69b0f790b3c3f70fbc61ae074fb /cmd/zpool/Makefile.am
parent92aceb2a7ee8c9367fdc901fed933f6f258173e0 (diff)
zpool iostat/status -c improvements
Users can now provide their own scripts to be run with 'zpool iostat/status -c'. User scripts should be placed in ~/.zpool.d to be included in zpool's default search path. Provide a script which can be used with 'zpool iostat|status -c' that will return the type of device (hdd, sdd, file). Provide a script to get various values from smartctl when using 'zpool iostat/status -c'. Allow users to define the ZPOOL_SCRIPTS_PATH environment variable which can be used to override the default 'zpool iostat/status -c' search path. Allow the ZPOOL_SCRIPTS_ENABLED environment variable to enable or disable 'zpool status/iostat -c' functionality. Use the new smart script to provide the serial command. Install /etc/sudoers.d/zfs file which contains the sudoer rule for smartctl as a sample. Allow 'zpool iostat/status -c' tests to run in tree. Reviewed-by: Tony Hutter <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #6121 Closes #6153
Diffstat (limited to 'cmd/zpool/Makefile.am')
-rw-r--r--cmd/zpool/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/cmd/zpool/Makefile.am b/cmd/zpool/Makefile.am
index f905fb73d..6eff1d143 100644
--- a/cmd/zpool/Makefile.am
+++ b/cmd/zpool/Makefile.am
@@ -36,12 +36,31 @@ dist_zpoolexec_SCRIPTS = \
zpool.d/label \
zpool.d/locate_led \
zpool.d/lsblk \
+ zpool.d/media \
zpool.d/model \
zpool.d/serial \
zpool.d/ses \
zpool.d/size \
zpool.d/slaves \
zpool.d/slot \
+ zpool.d/smart \
+ zpool.d/smartx \
+ zpool.d/temp \
+ zpool.d/health \
+ zpool.d/r_proc \
+ zpool.d/w_proc \
+ zpool.d/r_ucor \
+ zpool.d/w_ucor \
+ zpool.d/nonmed \
+ zpool.d/defect \
+ zpool.d/hours_on \
+ zpool.d/realloc \
+ zpool.d/rep_ucor \
+ zpool.d/cmd_to \
+ zpool.d/pend_sec \
+ zpool.d/off_ucor \
+ zpool.d/ata_err \
+ zpool.d/pwr_cyc \
zpool.d/upath \
zpool.d/vendor
@@ -55,12 +74,31 @@ zpoolconfdefaults = \
label \
locate_led \
lsblk \
+ media \
model \
serial \
ses \
size \
slaves \
slot \
+ smart \
+ smartx \
+ temp \
+ health \
+ r_proc \
+ w_proc \
+ r_ucor \
+ w_ucor \
+ nonmed \
+ defect \
+ hours_on \
+ realloc \
+ rep_ucor \
+ cmd_to \
+ pend_sec \
+ off_ucor \
+ ata_err \
+ pwr_cyc \
upath \
vendor