aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zpool/Makefile.am
diff options
context:
space:
mode:
authorPetros Koutoupis <[email protected]>2020-05-09 12:17:08 -0500
committerGitHub <[email protected]>2020-05-09 10:17:08 -0700
commitbd95f00d4b6aa185bf508f12d2cdbfbb2350b80e (patch)
tree91406e6f17adb10a51c178479c232719cedad692 /cmd/zpool/Makefile.am
parentd775c86dd4ced233ac0636607706cc5a08bcb923 (diff)
Fixed LDADD library links in Makefiles for cross compilation builds
When building on native dev system, there are no issues but when cross-compiling for target system, some linker errors are observed. The only way to avoid these errors is by adjusting the Makefile.am of those various components to add the library dependencies. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: George Melikov <[email protected]> Signed-off-by: Petros Koutoupis <[email protected]> Closes #10304
Diffstat (limited to 'cmd/zpool/Makefile.am')
-rw-r--r--cmd/zpool/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cmd/zpool/Makefile.am b/cmd/zpool/Makefile.am
index 7b25726f4..5efa13184 100644
--- a/cmd/zpool/Makefile.am
+++ b/cmd/zpool/Makefile.am
@@ -22,6 +22,7 @@ endif
zpool_LDADD = \
$(top_builddir)/lib/libnvpair/libnvpair.la \
$(top_builddir)/lib/libuutil/libuutil.la \
+ $(top_builddir)/lib/libzfs_core/libzfs_core.la \
$(top_builddir)/lib/libzfs/libzfs.la
if BUILD_FREEBSD