summaryrefslogtreecommitdiffstats
path: root/cmd/zinject/Makefile.am
diff options
context:
space:
mode:
authorDarik Horn <[email protected]>2011-12-31 17:30:52 -0600
committerBrian Behlendorf <[email protected]>2012-01-17 15:19:50 -0800
commit750562833f5009e1602e3b7d8f10497ee683f611 (patch)
treeb06e59864c4f9a6466cc6e0de486572809888618 /cmd/zinject/Makefile.am
parent57a4eddc4d5e1e6c10d8d7dcf87a9fc27398adcd (diff)
Combine libraries: spl, avl, efi, share, unicode.
These libraries, which are an artifact of the ZoL development process, conflict with packages that are already in distribution: * libspl: SPL Programming Language * libavl: AVL for Linux * libefi: GRUB And these libraries are potential conflicts: * libshare: the Linux Mount Manager * libunicode: Perl and Python Recompose these five ZoL components into the four libraries that are conventionally provided by Solaris and FreeBSD systems: + libnvpair + libuutil + libzpool + libzfs This change resolves the name conflict, makes ZoL more compatible with existing software that uses autotools to detect ZFS, and allows pkg-zfs to better reflect the official Debian kFreeBSD packaging. Signed-off-by: Brian Behlendorf <[email protected]> Closes: #430
Diffstat (limited to 'cmd/zinject/Makefile.am')
-rw-r--r--cmd/zinject/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/cmd/zinject/Makefile.am b/cmd/zinject/Makefile.am
index eb67b1569..d1d32d57f 100644
--- a/cmd/zinject/Makefile.am
+++ b/cmd/zinject/Makefile.am
@@ -12,11 +12,7 @@ zinject_SOURCES = \
$(top_srcdir)/cmd/zinject/zinject.h
zinject_LDADD = \
- $(top_builddir)/lib/libspl/libspl.la \
- $(top_builddir)/lib/libavl/libavl.la \
- $(top_builddir)/lib/libefi/libefi.la \
$(top_builddir)/lib/libnvpair/libnvpair.la \
- $(top_builddir)/lib/libunicode/libunicode.la \
$(top_builddir)/lib/libuutil/libuutil.la \
$(top_builddir)/lib/libzpool/libzpool.la \
$(top_builddir)/lib/libzfs/libzfs.la