summaryrefslogtreecommitdiffstats
path: root/cmd/zfs/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-02-10 10:57:29 -0800
committerBrian Behlendorf <[email protected]>2011-02-10 11:05:44 -0800
commit1ac0ea38a5b19771b0dfbc6b2244c4f674ef1a31 (patch)
tree55c69ba0d4da61494f8b9008e6ff4f535e2f6f30 /cmd/zfs/Makefile.am
parent6c9e06f14de1ed27e6032be2197b8f4cbec7405a (diff)
Add missing -ldl linker option
The inclusion on dlsym(), dlopen(), and dlclose() symbols require us to link against the dl library. Be careful to add the flag to both the libzfs library and the commands which depend on the library.
Diffstat (limited to 'cmd/zfs/Makefile.am')
-rw-r--r--cmd/zfs/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cmd/zfs/Makefile.am b/cmd/zfs/Makefile.am
index ba3e6447e..1b7cd841c 100644
--- a/cmd/zfs/Makefile.am
+++ b/cmd/zfs/Makefile.am
@@ -22,4 +22,4 @@ zfs_LDADD = \
$(top_builddir)/lib/libzpool/libzpool.la \
$(top_builddir)/lib/libzfs/libzfs.la
-zfs_LDFLAGS = -pthread -lm $(ZLIB) -lrt $(LIBUUID) $(LIBBLKID)
+zfs_LDFLAGS = -pthread -lm $(ZLIB) -lrt -ldl $(LIBUUID) $(LIBBLKID)