aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zed/Makefile.am
diff options
context:
space:
mode:
authorChris Dunlap <[email protected]>2015-02-26 16:26:48 -0800
committerBrian Behlendorf <[email protected]>2015-04-27 12:08:08 -0700
commita0d065fa922d2ce2e07785eb3d35757763c644bf (patch)
tree150b18e6857c67a384a30886db1f97281bdca31c /cmd/zed/Makefile.am
parent20967ff1a4c2ff3f706505222dd66b3b15645596 (diff)
Add support for Pushbullet notifications
This commit adds the zed_notify_pushbullet() function and hooks it into zed_notify(), thereby integrating it with the existing "notify" ZEDLETs. This enables ZED to push notifications to your desktop computer and/or mobile device(s). It is configured with the ZED_PUSHBULLET_ACCESS_TOKEN and ZED_PUSHBULLET_CHANNEL_TAG variables in zed.rc. https://www.pushbullet.com/ The Makefile install-data-local target has been replaced with install-data-hook. With the "-local" target, there is no particular guarantee of execution order. But with the zed.rc now potentially containing sensitive information (i.e., the Pushbullet access token), the recommended permissions have changed to 0600. The "-hook" target is always executed after the main rule's work is done; thus, the chmod will always take place after the zed.rc file has been installed. https://www.gnu.org/software/automake/manual/automake.html#Extending Signed-off-by: Chris Dunlap <[email protected]>
Diffstat (limited to 'cmd/zed/Makefile.am')
-rw-r--r--cmd/zed/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cmd/zed/Makefile.am b/cmd/zed/Makefile.am
index 09be2ca6c..f0d22411d 100644
--- a/cmd/zed/Makefile.am
+++ b/cmd/zed/Makefile.am
@@ -62,10 +62,11 @@ zedconfdefaults = \
resilver.finish-notify.sh \
scrub.finish-notify.sh
-install-data-local:
+install-data-hook:
$(MKDIR_P) "$(DESTDIR)$(zedconfdir)"
for f in $(zedconfdefaults); do \
test -f "$(DESTDIR)$(zedconfdir)/$${f}" -o \
-L "$(DESTDIR)$(zedconfdir)/$${f}" || \
ln -s "$(zedexecdir)/$${f}" "$(DESTDIR)$(zedconfdir)"; \
done
+ chmod 0600 "$(DESTDIR)$(zedconfdir)/zed.rc"