aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zdb/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2015-12-11 18:40:05 -0500
committerBrian Behlendorf <[email protected]>2015-12-14 12:53:09 -0800
commit27075111ed93f5290fbb5d801964aa20ed7a9d35 (patch)
treee91bdf2b0ebc6bef4dcac87cde3ade81aaac2510 /cmd/zdb/Makefile.am
parent245b7ab3d1c06efe5b76a9412996fac50aa77f72 (diff)
Unconditionally build zdb and ztest with -DDEBUG
Illumos unconditionally builds zdb and ztest with -DDEBUG. This helps catch bugs and eliminates the need for commits like 202619623022722f30c2ee49931a4fa6896421c7, which changed ASSERTs to VERIFYs. The following files in the illumos tree show this: usr/src/cmd/zdb/Makefile.com usr/src/cmd/ztest/Makefile.com Given the usefulness of having early failure in these tools, we should do it too. Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Issue #4095
Diffstat (limited to 'cmd/zdb/Makefile.am')
-rw-r--r--cmd/zdb/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cmd/zdb/Makefile.am b/cmd/zdb/Makefile.am
index bc47cffba..c22186a10 100644
--- a/cmd/zdb/Makefile.am
+++ b/cmd/zdb/Makefile.am
@@ -1,5 +1,7 @@
include $(top_srcdir)/config/Rules.am
+AM_CPPFLAGS += -DDEBUG
+
DEFAULT_INCLUDES += \
-I$(top_srcdir)/include \
-I$(top_srcdir)/lib/libspl/include