summaryrefslogtreecommitdiffstats
path: root/cmd/mount_zfs/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-03-04 15:14:46 -0800
committerBrian Behlendorf <[email protected]>2011-03-09 15:26:48 -0800
commitd53368f6755ff67342f68e2e536c4157409fd047 (patch)
treebe909c931e465df4757a67f9329ab9e2b1dc6941 /cmd/mount_zfs/Makefile.am
parentadf2e8778e66e6a749cec981da00463b342bd563 (diff)
Fix mount helper
Several issues related to strange mount/umount behavior were reported and this commit should address most of them. The original idea was to put in place a zfs mount helper (mount.zfs). This helper is used to enforce 'legacy' mount behavior, and perform any extra mount argument processing (selinux, zfsutil, etc). This helper wasn't ready for the 0.6.0-rc1 release but with this change it's functional but needs to extensively tested. This change addresses the following open issues. Closes #101 Closes #107 Closes #113 Closes #115 Closes #119
Diffstat (limited to 'cmd/mount_zfs/Makefile.am')
-rw-r--r--cmd/mount_zfs/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/cmd/mount_zfs/Makefile.am b/cmd/mount_zfs/Makefile.am
new file mode 100644
index 000000000..f5d2db0ba
--- /dev/null
+++ b/cmd/mount_zfs/Makefile.am
@@ -0,0 +1,28 @@
+include $(top_srcdir)/config/Rules.am
+
+DEFAULT_INCLUDES += \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/lib/libspl/include
+
+#
+# Ignore the prefix for the mount helper. It must be installed in /sbin/
+# because this path is hardcoded in the mount(8) for security reasons.
+#
+sbindir=/sbin
+sbin_PROGRAMS = mount.zfs
+
+mount_zfs_SOURCES = \
+ $(top_srcdir)/cmd/mount_zfs/mount_zfs.c
+
+mount_zfs_LDADD = \
+ $(top_builddir)/lib/libspl/libspl.la \
+ $(top_builddir)/lib/libavl/libavl.la \
+ $(top_builddir)/lib/libefi/libefi.la \
+ $(top_builddir)/lib/libnvpair/libnvpair.la \
+ $(top_builddir)/lib/libunicode/libunicode.la \
+ $(top_builddir)/lib/libuutil/libuutil.la \
+ $(top_builddir)/lib/libzpool/libzpool.la \
+ $(top_builddir)/lib/libzfs/libzfs.la
+
+mount_zfs_LDFLAGS = \
+ -pthread -lm $(ZLIB) -lrt -ldl $(LIBUUID) $(LIBBLKID)