aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/arcstat/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-09 04:09:55 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:18:38 -0700
commit5cdca5b1da7884c54260db473f892354bc79951b (patch)
tree6bdce13ac507fd450359dde2b3fa10405a480c54 /cmd/arcstat/Makefile.am
parent3ff81c460114e0b3f69a9993d4777ec2c590fb16 (diff)
autoconf: use include directives instead of recursing down cmd
No installation diff, dist lost -zfs-2.1.99/cmd/fsck_zfs/fsck.zfs which was distributed erroneously, since it's generated Also clean gitrev on clean Also add -e 'any possible bashisms' to default checkbashisms flags, and fully parallelise it and shellcheck, and it works out-of-tree, too Also align the Release in the dist META file correctly Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'cmd/arcstat/Makefile.am')
-rw-r--r--cmd/arcstat/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/cmd/arcstat/Makefile.am b/cmd/arcstat/Makefile.am
index d1ba989a0..d7fd81074 100644
--- a/cmd/arcstat/Makefile.am
+++ b/cmd/arcstat/Makefile.am
@@ -1,5 +1,4 @@
-include $(top_srcdir)/config/Substfiles.am
-
-bin_SCRIPTS = arcstat
-
-SUBSTFILES += $(bin_SCRIPTS)
+bin_SCRIPTS += arcstat
+CLEANFILES += arcstat
+EXTRA_DIST += %D%/arcstat.in
+$(call SUBST,arcstat,%D%/)