aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/Makefile.am
diff options
context:
space:
mode:
authorDamian Szuberski <[email protected]>2022-02-07 20:59:09 +0100
committerGitHub <[email protected]>2022-02-07 11:59:09 -0800
commit8df0bde321ab6e4c38cf17e89c8bc331369c7f0a (patch)
tree3d246b6ce734ec681dedecf9e716ddc35dc272e5 /cmd/Makefile.am
parentadd15e9539db945a76363f3b236ebc8fb2c69390 (diff)
Add `--enable=all` to ShellCheck by default
Change enforced shell type from `dash` to `sh` and excluded `SC2039` and `SC3043` by default. `local` keyword is accepted by all POSIX shells from practical point of view. There is no need anymore to enforce dash so `local` is accepted. Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: szubersk <[email protected]> Closes #13020
Diffstat (limited to 'cmd/Makefile.am')
-rw-r--r--cmd/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/cmd/Makefile.am b/cmd/Makefile.am
index 3994d1434..68f1e892d 100644
--- a/cmd/Makefile.am
+++ b/cmd/Makefile.am
@@ -9,7 +9,6 @@ CPPCHECKDIRS += raidz_test zfs_ids_to_path zpool_influxdb
# TODO: #12084: SHELLCHECKDIRS += vdev_id
SHELLCHECKDIRS = fsck_zfs zed zpool zvol_wait
-SHELLCHECK_OPTS = --enable=all
if USING_PYTHON
SUBDIRS += arcstat arc_summary dbufstat