summaryrefslogtreecommitdiffstats
path: root/cmd/Makefile.am
diff options
context:
space:
mode:
authorRichard Elling <[email protected]>2020-10-09 09:29:21 -0700
committerGitHub <[email protected]>2020-10-09 09:29:21 -0700
commite9527d44e655fe6fda4f154b396a1e5890abc539 (patch)
treec067e15eb1c12304121bf62acbe79c5cba6bd7a6 /cmd/Makefile.am
parentb7ab7ae2410f5152318cbb71675e9ba94d7562cb (diff)
Add zpool_influxdb command
A zpool_influxdb command is introduced to ease the collection of zpool statistics into the InfluxDB time-series database. Examples are given on how to integrate with the telegraf statistics aggregator, a companion to influxdb. Finally, a grafana dashboard template is included to show how pool latency distributions can be visualized in a ZFS + telegraf + influxdb + grafana environment. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Richard Elling <[email protected]> Closes #10786
Diffstat (limited to 'cmd/Makefile.am')
-rw-r--r--cmd/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cmd/Makefile.am b/cmd/Makefile.am
index 88d32b1c5..d99d1dc38 100644
--- a/cmd/Makefile.am
+++ b/cmd/Makefile.am
@@ -1,5 +1,6 @@
SUBDIRS = zfs zpool zdb zhack zinject zstream zstreamdump ztest
SUBDIRS += fsck_zfs vdev_id raidz_test zfs_ids_to_path
+SUBDIRS += zpool_influxdb
if USING_PYTHON
SUBDIRS += arcstat arc_summary dbufstat