summaryrefslogtreecommitdiffstats
path: root/cmd/Makefile.am
diff options
context:
space:
mode:
authorRyan Moeller <[email protected]>2019-11-11 12:24:04 -0500
committerBrian Behlendorf <[email protected]>2019-11-11 09:24:04 -0800
commit2f1ca8a32af1c405fc5735673cc3f24f35465b68 (patch)
tree207bd377d01c8597e89ec402d6b2628e8593d57f /cmd/Makefile.am
parent6c7023a5326cc999cfaced931ee2498642d5e63f (diff)
Isolate code specific to Linux in cmd/
Use sys.platform to choose the correct implementation of functions and values of variables for the platform being run on. Reword some comments to avoid describing implementation details in the wrong places. Reviewed-by: Kjeld Schouten <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Jorgen Lundman <[email protected]> Signed-off-by: Ryan Moeller <[email protected]> Closes #9561
Diffstat (limited to 'cmd/Makefile.am')
-rw-r--r--cmd/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cmd/Makefile.am b/cmd/Makefile.am
index 88609e455..90270209b 100644
--- a/cmd/Makefile.am
+++ b/cmd/Makefile.am
@@ -5,4 +5,6 @@ if USING_PYTHON
SUBDIRS += arcstat arc_summary dbufstat
endif
+if BUILD_LINUX
SUBDIRS += mount_zfs zed zvol_id zvol_wait
+endif