aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-10-25 13:58:45 -0700
committerBrian Behlendorf <[email protected]>2013-10-25 14:52:45 -0700
commitd738d34da5b25b5e5daef966c29386468fd16263 (patch)
tree9cd97bc1866b61b6539970b36aa02a3493401585 /cmd/Makefile.am
parente0b0ca983d6897bcddf05af2c0e5d01ff66f90db (diff)
Add dbufstat.py command
The dbufstat.py command was added to provide a conveniant way to easily determine what ZFS is caching. The script consumes the raw /proc/spl/kstat/zfs/dbufs kstat data can consolidates it in to a more human readable form. This was designed primarily as a tool to aid developers but it may also be useful for advanced users who want more visibility in to what the ARC is caching. When run without options dbufstat.py will default to showing a list of all objects with at least one buffer present in the cache. The total cache space consumed by that object will be printed on the right along with the object type. Similar to the arcstats.py command the -x option may used to display additional fields. Two other modes of operation are also supported by dbufstat.py and the expectation is additional display modes may be added as needed. The -t option will summerize the total number of bytes cached for each object type, and the -b option will show every dbuf currently cached. The script was designed to be consistent with arcstat.py and includes most of the same options and funcationality. Signed-off-by: Prakash Surya <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'cmd/Makefile.am')
-rw-r--r--cmd/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cmd/Makefile.am b/cmd/Makefile.am
index bad1af63e..4c3e4bbb2 100644
--- a/cmd/Makefile.am
+++ b/cmd/Makefile.am
@@ -1,2 +1,2 @@
SUBDIRS = zfs zpool zdb zhack zinject zstreamdump ztest zpios
-SUBDIRS += mount_zfs fsck_zfs zvol_id vdev_id arcstat
+SUBDIRS += mount_zfs fsck_zfs zvol_id vdev_id arcstat dbufstat