aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2011-03-04 15:14:46 -0800
committerBrian Behlendorf <[email protected]>2011-03-09 15:26:48 -0800
commitd53368f6755ff67342f68e2e536c4157409fd047 (patch)
treebe909c931e465df4757a67f9329ab9e2b1dc6941 /cmd/Makefile.am
parentadf2e8778e66e6a749cec981da00463b342bd563 (diff)
Fix mount helper
Several issues related to strange mount/umount behavior were reported and this commit should address most of them. The original idea was to put in place a zfs mount helper (mount.zfs). This helper is used to enforce 'legacy' mount behavior, and perform any extra mount argument processing (selinux, zfsutil, etc). This helper wasn't ready for the 0.6.0-rc1 release but with this change it's functional but needs to extensively tested. This change addresses the following open issues. Closes #101 Closes #107 Closes #113 Closes #115 Closes #119
Diffstat (limited to 'cmd/Makefile.am')
-rw-r--r--cmd/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cmd/Makefile.am b/cmd/Makefile.am
index af03994ce..eaa90d4b9 100644
--- a/cmd/Makefile.am
+++ b/cmd/Makefile.am
@@ -1 +1,2 @@
-SUBDIRS = zfs zpool zpool_id zpool_layout zdb zinject ztest zpios zvol_id
+SUBDIRS = zfs zpool zdb zinject ztest zpios mount_zfs
+SUBDIRS += zpool_layout zvol_id zpool_id