summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorloli10K <[email protected]>2019-05-24 23:12:14 +0200
committerBrian Behlendorf <[email protected]>2019-05-24 14:12:14 -0700
commitfe609530f2333054eeffd08ebef8c227a9730085 (patch)
treea4359e7d87315bc338d70eadf0e73dc499dbf235 /Makefile.am
parentd28b492ab374675df0b94f83aa6bfbca2d8264f9 (diff)
zfs-tests: fix warnings when packaging some .shlib files
This change prevents the following warning when packaging some zfs-tests files: *** WARNING: ./usr/src/zfs-0.8.0/tests/zfs-tests/include/zpool_script.shlib is executable but has empty or no shebang, removing executable bit Reviewed by: John Kennedy <[email protected]> Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Giuseppe Di Natale <[email protected]> Signed-off-by: loli10K <[email protected]> Closes #8787
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b4416c749..1ec251492 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -111,9 +111,10 @@ mancheck:
fi
testscheck:
- @find ${top_srcdir}/tests/zfs-tests/tests -type f \
+ @find ${top_srcdir}/tests/zfs-tests -type f \
\( -name '*.ksh' -not -executable \) -o \
\( -name '*.kshlib' -executable \) -o \
+ \( -name '*.shlib' -executable \) -o \
\( -name '*.cfg' -executable \) | \
xargs -r stat -c '%A %n' | \
awk '{c++; print} END {if(c>0) exit 1}'