summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2012-12-16 00:35:16 -0500
committerBrian Behlendorf <[email protected]>2012-12-17 09:45:47 -0800
commitfd7fd5ebcf6cceb107dd27592a9bd7d60f93738f (patch)
tree21ec00c3e61e8710e4d8752da6ff3543cc4e058c /Makefile.am
parent8780c53961e668211682d40ad36946294c3145d8 (diff)
Do not use KERNEL_DIR env var in Makefile.am
A Gentoo user reported an issue where the build system would attempt to recurse into the kernel source tree if KERNEL_DIR is set in the environment. KERNEL_DIR is an environment variable that is used when the kernel sources are in a non-standard location, so it is necessary to stop relying on it to prevent this issue. https://bugs.gentoo.org/show_bug.cgi?id=433946 Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ffd6be7b..833bee64e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,13 +3,13 @@ include $(top_srcdir)/config/deb.am
include $(top_srcdir)/config/tgz.am
include $(top_srcdir)/config/arch.am
+SUBDIRS = include
if CONFIG_USER
-USER_DIR = dracut udev etc man scripts lib cmd
+SUBDIRS += dracut udev etc man scripts lib cmd
endif
if CONFIG_KERNEL
-KERNEL_DIR = module
+SUBDIRS += module
endif
-SUBDIRS = $(USER_DIR) $(KERNEL_DIR) include
AUTOMAKE_OPTIONS = foreign
EXTRA_DIST = autogen.sh zfs.spec.in zfs-modules.spec.in